Announcing AstraSync 4.2 Public Beta 2

We are pleased to announce AstraSync 4.2 Beta 2

AstraSync now supports alert profile integration through Monitor for BlackBerry, meeting request creation, email content encryption, kinetic scrolling and more performance settings for power users.

‘Monitor for BlackBerry’ program (required for profile integration) requires OS 4.7 and later.

Major Enhancements

The following improvements have been made in AstraSync 4.2 Beta over AstraSync 4.1:

  • Closer integration with the device OS through Monitor (A new monitoring program for BlackBerry). Providing integrated device profile alerts for new messages including LED notifications, better network availability awareness and faster performance.
  • Support for creation of meetings requests
  • Email content encryption.
  • Kinetic scrolling of the message list on touch screen devices.
  • Leaner, faster message store system
  • More performance settings for power users including control of Direct Push behavior, email truncation size, PIM status checks and AutoDiscover.

AstraSync 4.2 includes other enhancements and bug fixes – please refer to the release notes for a list of the most important resolved issues.

Installation

To download this version, visit the AstraSync beta portal with your BlackBerry browser: http://www.astrasync.com/beta.

You will need to provide your AstraSync account credentials (email address and password).

You can upgrade from AstraSync 2.2.x, 3.0.X, 3.1.X, 4.0.x, 4.1.x to this AstraSync build, however some older devices are not supported for this build.

Supported Devices

This is not an exhaustive list if your device is not listed below or in the Unsupported devices list then it may support AstraSync 4.1

82XX Flip devices running OS 4.5 and later
83XX Curve devices running OS 4.5 and later
85XX Curve devices running OS 4.6 and later
88XX devices running OS 4.5 and later
8900 Curve devices running OS 4.6 and later
9000 Bold devices running OS 4.6 and later
95XX Storm 1 and 2 devices running OS 4.7 and later
96XX Tour devices running OS 4.7 and later
9700 Bold devices running OS 5.0 and later

Note: the ‘Monitor for BlackBerry’ program requires OS 4.7 and later.

Unsupported Devices

7XXX devices
81xx Pearl devices
87xx devices

Release notes can be found at http://www.astrasync.com/beta/astrasync-release-notes.htm

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: